Monitor Forum | Start New Thread Start New Thread
RE: Message dans ACC : Connexion internet désactivée revient chaque jour [ Reply ]
By: François Garnier on 2021-01-14 09:13
[forum:489970]
J'ai fait ce que tu m'as dit... et depuis 2 jours plus de déconnexions !
Vraiment merci de m'avoir ôté cette épine, c'était simple, mais comme je ne connais pas bien encore Alcasar, pédagogique aussi ;)
Je vais pouvoir donner cette machine à l'association qui va l'utiliser pour aider les personnes en difficulté avec l'informatique dans un quartier prioritaire.

RE: Message dans ACC : Connexion internet désactivée revient chaque jour [ Reply ]
By: Laurent roux on 2021-01-12 13:32
[forum:489967]
Hello,

En DNS1, tu mets l'IP de ta box puis tu fais alcasar-conf.sf --apply et reboot ...

RE: Message dans ACC : Connexion internet désactivée revient chaque jour [ Reply ]
By: François Garnier on 2021-01-12 09:57
[forum:489964]
Merci Laurent pour la réponse.

Voici le contenu de mon fichier alcasar.conf :
##########################################
## ##
## ALCASAR Parameters ##
## ##
##########################################
INSTALL_DATE=31 décembre 2020 - 12h15
VERSION=3.5.2
ORGANISM=Cria41
HOSTNAME=alcasar
DOMAIN=localdomain
EXTIF=eno1
INTIF=enp3s2
LANIF=lo
PUBLIC_IP=dhcp
GW=dhcp
DNS1=8.8.8.8
DNS2=8.8.4.4
PUBLIC_MTU=1500
PRIVATE_IP=192.168.182.1/24
DHCP=on
EXT_DHCP_IP=
RELAY_DHCP_IP=
RELAY_DHCP_PORT=
INT_DNS_DOMAIN=
INT_DNS_IP=
INT_DNS_ACTIVE=off
HTTPS_LOGIN=off
HTTPS_CHILLI=off
SSH=on
SSH_ADMIN_FROM=0.0.0.0/0.0.0.0
LDAP=off
LDAP_SERVER=127.0.0.1
LDAP_BASE=cn=Users;dc=serverad;dc=localdomain
LDAP_UID=sAMAccountName
LDAP_FILTER=
LDAP_USER=alcasar
LDAP_PASSWORD=
LDAP_SSL=on
LDAP_CERT_REQUIRED=
SMS=off
SMS_NUM=
MULTIWAN=off
FAILOVER=30
## WANx=active,@IPx/mask,GWx,Weight,MTUx
#WAN1="1,eno1:1,192.168.2.20/24,192.168.2.6,1,1500"
#WAN2="1,eno1:2,192.168.3.20/24,192.168.3.1,2,1500"
BL_PUREIP=off
BL_SAFESEARCH=off
WL_SAFESEARCH=off
IOT_CAPTURE=off

RE: Message dans ACC : Connexion internet désactivée revient chaque jour [ Reply ]
By: Laurent roux on 2021-01-11 22:19
[forum:489961]
Pouvez-vous envoyer ou copier-coller votre fichier de config ?
alcasar.conf .....

RE: Message dans ACC : Connexion internet désactivée revient chaque jour [ Reply ]
By: François Garnier on 2021-01-10 18:19
[forum:489959]

alacasar - journalctl - dhclient (3) downloads
Bonjour,

J'ai mis l'IP du serveur Alcasar dans un bail statique sur ma box (Livebox 3) comme préconisé. Mais cela n'a pas empêché la désactivation habituelle.
Pour information si ça peut servir je vous joint le résultat de la commande :
journalctl | grep dhclient
pour les 10 derniers jours. La box a toujours donné la même IP à Alcasar.

RE: Message dans ACC : Connexion internet désactivée revient chaque jour [ Reply ]
By: Richard REY (Rexy) on 2021-01-09 11:46
[forum:489957]

Screenshot_20210108_110742.png (4) downloads
Bonjour,

Nous testons actuellement ALCASAR sur virtualisateur pour reproduire vos constats.
Votre fichier joint montre bien un renouvellement de bail DHCP, puis DNSMASQ qui tente de se synchroniser avec ce renouvellement.
Un premier conseil est de fixer l'adresse IP fournie par le serveur DHCP de votre Box à ALCASAR afin que celle-ci ne bouge pas avec le temps. Pour cela, allez dans la configuration de votre BOX pour associer l'adresse MAC de la carte réseau d'ALCASAR avec une adresse IP (vous trouvez cette adresse MAC sur la page d’accueil de l'ACC / information système / Réseau (cf. pj).

RE: Message dans ACC : Connexion internet désactivée revient chaque jour [ Reply ]
By: François Garnier on 2021-01-08 17:39
[forum:489955]

message alcasar 2 (6) downloads
Pour compléter mon message précédent, j'ai trouvé dans mes logs le moment précis où la connexion passe sur le statut Désactivée.
Cela semble-t-il confirmer le problème lié au DHCP ?

Je me permet de reposer la question : une modification du fichier alacasar.conf pour passer les paramètres en IP fixe serait-il suffisant sans devoir faire de réinstallation d'Alcasar ou pire de la Mageia ?


RE: Message dans ACC : Connexion internet désactivée revient chaque jour [ Reply ]
By: François Garnier on 2021-01-06 07:09
[forum:489948]
Merci pour votre réponse.

- effectivement lorsque la connexion est désactivée (ou du moins semble l'être) le bandeau est persistant sur le navigateur mais j'étais bien connecté sur alcasar comme utilisateur et je pouvais accéder aux sites en https (et seulement ceux-là, la copie d'écran ne s'affiche que pour les sites en http)

- je me doutais bien que le dhcp externe pouvait être cause de problèmes mais je voulais pouvoir déplacer facilement le serveur alcasar sur un autre site sans devoir le reparamétrer.
Questions :
- est-il possible de passer en ip fixe sur la carte ethernet externe sans devoir réinstaller alcasar, juste en modifiant le fichier alcasar.conf ?
- lorsque vous parlez de réinstallation, c'est alcasar ou aussi la Mageia ?

Une remarque liée au forum : si je veux publier le commentaire depuis Firefox sous Linux j'ai systématiquement le message Vous essayez de publier deux fois le même message... et ça ne passe pas.

RE: Message dans ACC : Connexion internet désactivée revient chaque jour [ Reply ]
By: Richard REY (Rexy) on 2021-01-05 22:42
[forum:489947]
Bonjour,
J'ai deux remarques :
- sur votre copie d'écran, vous semblez ne pas vous être connecté à ALCASAR (bandeau du navigateur qui demande à vous connecter)
- vous avez configuré votre ALCASAR en DHCP (adresse fournie dynamiquement par votre Box). Ce n'est pas super conseillé, car certaines Box ont tendance à forcer des changements d'adresse. Tenter une réinstallation avec une adresse statique que vous fixez.

Message dans ACC : Connexion internet désactivée revient chaque jour [ Reply ]
By: François Garnier on 2021-01-05 18:54
[forum:489945]

Capture du 2021-01-05 18-11-51.png (6) downloads
Bonjour,
J'ai installé pour test Alcasar 3.5.2, avant installation dans une association de lutte contre l'illectronisme, sur une machine dédiée.
Depuis le début j'ai le message Connexion internet désactivée, visible depuis l'ACC, qui revient après un certain temps d'inactivité.
J'ai mis en crontab un redémarrage à 6h du matin, deux heures après la connexion est encore active (coche vert) mais en fin de journée elle est repassée en désactivée. J'ai essayé aussi de maintenir de l'activité réseau avec un ping tout les 5mn mais ça ne change rien.
Bizarrement lorsque la Connexion internet est affichée désactivée, il est toujours possible de naviguer, après authentification, sur les sites https mais ceux en http sont bloqués (cf PJ).
Le ping sur un nom de domaine ne fonctionne plus depuis le serveur non plus ce qui semble indiquer un problème sur les DNS mais je ne comprend pas pourquoi cela fonctionne, puis plus...

Voici le contenu de mon fichier alcasar.conf :
##########################################
## ##
## ALCASAR Parameters ##
## ##
##########################################
INSTALL_DATE=31 décembre 2020 - 12h15
VERSION=3.5.2
ORGANISM=Cria41
HOSTNAME=alcasar
DOMAIN=localdomain
EXTIF=eno1
INTIF=enp3s2
LANIF=lo
PUBLIC_IP=dhcp
GW=dhcp
DNS1=8.8.8.8
DNS2=8.8.4.4
PUBLIC_MTU=1500
PRIVATE_IP=192.168.182.1/24
DHCP=on
EXT_DHCP_IP=
RELAY_DHCP_IP=
RELAY_DHCP_PORT=
INT_DNS_DOMAIN=
INT_DNS_IP=
INT_DNS_ACTIVE=off
HTTPS_LOGIN=off
HTTPS_CHILLI=off
SSH=on
SSH_ADMIN_FROM=0.0.0.0/0.0.0.0
LDAP=off
LDAP_SERVER=127.0.0.1
LDAP_BASE=cn=Users;dc=serverad;dc=localdomain
LDAP_UID=sAMAccountName
LDAP_FILTER=
LDAP_USER=alcasar
LDAP_PASSWORD=
LDAP_SSL=on
LDAP_CERT_REQUIRED=
SMS=off
SMS_NUM=
MULTIWAN=off
FAILOVER=30
## WANx=active,@IPx/mask,GWx,Weight,MTUx
#WAN1="1,eno1:1,192.168.2.20/24,192.168.2.6,1,1500"
#WAN2="1,eno1:2,192.168.3.20/24,192.168.3.1,2,1500"
BL_PUREIP=off
BL_SAFESEARCH=off
WL_SAFESEARCH=off
IOT_CAPTURE=off

Merci d'avance si vous pouvez me donner des pistes pour corriger ce problème. Cordialement.

FEDER Powered By FusionForge Collaborative Development Environment Charte d'utilisation / Nous contacter / Mentions légales Haut de page